OAuth Exception occurred: signature_invalid started occuring in WP8 app

Topics: Developer Forum, User Forum
Sep 19, 2013 at 6:18 AM
I have been working on a Flickr app for Windows Phone 8 for the past few weeks. I have been using Flickrnet the whole time and things have worked splendidly. Then all of a sudden tonight the auth just stopped working and started returning the signature_invalid error. I haven't changed anything related to auth and even when I try to register on an older version of the app when I knew the code to have been working, I still get this error.

What could have changed to lead to this error?

Here is the error in full:
{FlickrNet.OAuthException: OAuth Exception occurred: signature_invalid ---> System.Net.WebException: The remote server returned an error: NotFound. ---> System.Net.WebException: The remote server returned an error: NotFound. at System.Net.Browser.ClientHttpWebRequest.InternalEndGetResponse(IAsyncResult asyncResult) at System.Net.Browser.ClientHttpWebRequest.<>c__DisplayClasse.<EndGetResponse>b__d(Object sendState) at System.Net.Browser.AsyncHelper.<>c__DisplayClass1.<BeginOnUI>b__0(Object sendState) --- End of inner exception stack trace --- at System.Net.Browser.AsyncHelper.BeginOnUI(SendOrPostCallback beginMethod, Object state) at System.Net.Browser.ClientHttpWebRequest.EndGetResponse(IAsyncResult asyncResult) at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result) at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result) --- End of inner exception stack trace ---}

Any help would be greatly appreciated. The app is currently in beta testing in the Windows Phone store and I don't want this to block any of my testers. Here is a link for those curious:
Sep 19, 2013 at 3:06 PM
A number of users on the Flickr API group have also been experiencing this issue, so it might not be an issue with your app:


I'll try and knock together a quick app in the emulator (I've only got a 7.5 phone so can't test your app live I'm afraid) and see if I can reproduce.

Have you got the latest nuget package?

Sep 27, 2013 at 8:05 PM
Seems to be resolved on Flickr's end. Thanks for looking into this.