PhotosAddTags not working

Topics: Developer Forum
Feb 23, 2009 at 4:39 PM

I've the following small code snippet based on the Coding4Fun example to authenticate with my account & then add some tags to a photo.

textBox1 contains the ID of the photo and its definitely correct.
textBox2 contains a list of line-seperated tags.

        public string Frob { get; set; }
        public string AuthToken { get; set; }
        public string APIKey { get; set; }
        public string SecretKey { get; set; }
        private void button1_Click(object sender, EventArgs e)
        {
            FlickrNet.Flickr flickr = new FlickrNet.Flickr(APIKey, SecretKey);
            Frob = flickr.AuthGetFrob();
            string url = flickr.AuthCalcUrl(Frob, FlickrNet.AuthLevel.Write);
            System.Diagnostics.Process.Start(url);
        }
        private void button2_Click(object sender, EventArgs e)
        {
            FlickrNet.Flickr flickr = null;
            if (string.IsNullOrEmpty(AuthToken))
            {
                flickr = new FlickrNet.Flickr(APIKey, SecretKey);
                FlickrNet.Auth auth = flickr.AuthGetToken(Frob);
                AuthToken = auth.Token;
            }
            flickr = new FlickrNet.Flickr(APIKey, SecretKey, AuthToken);
            string tags = textBox2.Text.Replace(Environment.NewLine, ",");
            flickr.PhotosAddTags(textBox1.Text, tags);
        }

as you can see, it's pretty simple.

button1 (the auth button), gets a frob & auth url and fires it up in the browser

button2 (the "save" button), takes the auth token and attempts to add the list of tags.

Theres no exceptions thrown, but the tags never appear on Flickr. Can anyone tell me if this is a known issue, or am I doing something horrendously stupid.