Godaddy (medium trust) issues

Topics: Developer Forum, User Forum
Feb 3, 2009 at 3:52 AM
I am wondering if anyone has been successful running a flickrnet application on Godaddy?  They are medium trust but say that the permissions have been modified to allow outbound http & https access.  I am unable to get past the System.Security.SecurityException: Request for the permission of type 'System.Net.WebPermission.

Anyone have experience with them?  Thanks in advance.
Coordinator
Feb 3, 2009 at 8:58 AM
Hi

A simple test would be to write a web page that made a simple web request to the Flickr servers, e.g.:

HttpWebRequest req = (HttpWebRequest)HttpWebRequest.Create("http://www.flickr.com");
HttpWebResponse res = (HttpWebResponse)req.GetResponse();

If the above two lines of code work, then you should be good to go, however if they don't then it is definitely Godaddy's fault.

If they do work then I'd be at a bit of a loss however, as that is basically all my code does.

Sam
Feb 6, 2009 at 5:28 AM
Thanks Sam.  No luck with the above code.  Still receiving a security exception.  I will try and get a response from godaddy support to see what they say but am expecting a canned reply.  Thanks again.
May 17, 2009 at 5:51 AM

Now working on godaddy.  I initially had a proxy server set up (I don't recall why and had forgotten it was there).  Removed it and godaddy now allows outbound http requests.

Jul 15, 2009 at 8:29 PM

I'm having the same problem, but can't seem to figure it out.  I don't know where I would have set a proxy server up or I'd check that out.

Coordinator
Jul 15, 2009 at 10:06 PM

You can configure a proxy in one of three places. Two are in the web.config file, either in a <system.net> section or the <flickrnet> section. The other place is in code, setting the Flickr.Proxy property.

If you haven't configured a proxy then that is unlikely to be the problem.

Have you tried the above code on its own? Are you also using godaddy?

Aug 5, 2009 at 9:52 PM

Sorry it took so long to post back.

Yes I am using GoDaddy.  I forgot to mention that before.  I checked my web.config file and I don't have either of those sections in it.  I'm coming down on a deadline now so this issue has a bigger priority now.  Do you know of a host similar to GoDaddy (in price and function) that would work with the flickr api?

Thanks again!

Coordinator
Aug 6, 2009 at 7:22 AM

I have had other people contact me regarding godaddy - they managed to resolve it eventually by contacting Flickr as the particular IP address they had been given by godaddy had been black listed.

I don't know of any other ISPs I'm afraid. If you do find one please post back though so others can find out.

Aug 10, 2009 at 9:12 PM

Sam,

Thanks for getting back to me.  I was able to run this code successfully using my GoDaddy account:

        Dim req As HttpWebRequest = HttpWebRequest.Create("http://www.flickr.com")
        req.Method = WebRequestMethods.Http.Get
        Dim res As HttpWebResponse = req.GetResponse()

        Response.Write("Test Success")
For some reason I still receive this error when using my other code:
Thanks for your help.
Coordinator
Aug 11, 2009 at 8:30 AM

If you read the stack trace you will see the last FlickrNet class is the PersistentCache class, and the error is a FileIOPermission exception. Therefore it is easy to surmise that it is failing to write the cache because it doesn't have file permissions.

Either set the CacheLocation to a directory you have permission to write to, or set CacheDisabled to true to disable caching completely.

Aug 27, 2009 at 9:44 PM

Sam thanks for all of your help.  Disabling the cache worked perfectly.

Thanks again!!!!