Method requires authentication but no token supplied

Topics: User Forum
Sep 20, 2013 at 9:07 AM
I am trying to call these methods from FlickrNetSamples Photostream page:

Flickr f = FlickrManager.GetAuthInstance();
CollectionInfo CollecInf = f.CollectionsGetInfo("7105944-72157625110456705");
or
BlogCollection bloglist = f.BlogsGetList();

but I always get the exception:
Method requires authentication but no token supplied.

Isn't GetAuthInstance() method creating and supplying the token? Or am I missing something?

Thanks in advance.
Coordinator
Sep 20, 2013 at 12:13 PM
It should, assuming you have actually authenticated.

So if you are using the web project, click on the link to Authenticate, then after authenticating (and you've got your access token in your cookie) click on the photostream example.
Sep 20, 2013 at 3:39 PM
Thanks for your prompt reply and for mentioning cookies. It seems, indeed a cookie problem. I tried on firefox and chrome and after authenticating it worked as expected. The problem is only on IE. I already delete the old cookies, set to accept all cookies, delete temp files, reset IE settings, restart PC!..., but it seems IE is not reading/writing the cookie with the token, hence the exception. Any idea how can I solve this? Thanks again!
Coordinator
Sep 22, 2013 at 8:47 PM
I've updated the code, and also put it up on a windows azure web site:

http://wackylabs.azurewebsites.net/Default.aspx

You can now see the code in action. I've tried it in IE 10 and it works fine (although I have modified it slightly now).

Sam