PhotosGetInfo and PhotosGeoGetLocation methods are not working..

Topics: Developer Forum
Dec 26, 2010 at 3:53 PM

First, thanks for developing this comfortable API.

I want to get information for each photo in the PhotoCollection.

But

foreach (Photo photo in photoSet)
{
   PhotoInfo info = flickr.PhotosGetInfo(photo.PhotoId);
   PlaceInfo loc = flickr.PhotosGeoGetLocation(photo.PhotoId);

Since a few weeks ago, this code has not been worked suddenly.

I found some articles and other guys had same problems in Oct.

But I use the lastest version of this API..

Can someone give me a hand? T_T

I have to collect Flickr photo information for my thesis. But now I can't collect anything..

Coordinator
Dec 26, 2010 at 4:03 PM

a) What do you mean, "not working" - are you getting an error perhaps?

b) If it was working and now is not and you didn't change anything then it isn't my code, but something further down the line.

Sam

Dec 27, 2010 at 12:21 AM

Thank you very much for your prompt response.

"not working" means that program is stopped that line and don't return any result, just stop and wait permanently.

It worked well before and I  didn't change anything. Also I checked input parameter, PhotoId value is correct..

should I use PhotosGetInfoAsync? I don't know the difference between PhotosGetInfo and PhotosGetInfoAsync.

 

Coordinator
Dec 27, 2010 at 8:33 AM

Can you double check you are using the very latest version as there was a bug in PhotosGetInfo which has already been fixed.

Sam

May 8, 2012 at 7:21 AM
jaeyoung wrote:

Thank you very much for your prompt response.

"not working" means that program is stopped that line and don't return any result, just stop and wait permanently.

It worked well before and I  didn't change anything. Also I checked input parameter, PhotoId value is correct..

should I use PhotosGetInfoAsync? I don't know the difference between PhotosGetInfo and PhotosGetInfoAsync.

 

hi Sam,

I had the same error when using flickr.PhotosGetInfo(photoId) method and I found it only occur in case that the photo is set unknown location ( photo's location = "A place with no name." in "Add this photo to your map" page ). If I remove the location or edit it to the valid location , I will pass the error. so, Please checking and fixing the method, thanks!

Coordinator
May 8, 2012 at 8:09 AM

Thanks for that. I wasn't aware there was such as place as "A place with no name" on the map page. I don't see it anywhere.

Do you have the ID of a photo that is in this place so I can reproduce the error.

Sam

Aug 9, 2013 at 3:03 PM
I got the same problem when I was querying a photo with ID: "54071193"
Coordinator
Aug 28, 2013 at 3:43 PM
Finally found the cause for this, and its fixed in the latest source code, which I hope to release in the next week or so.