This project has moved and is read-only. For the latest updates, please go here.

Photo Search with Geo data problem

Jun 4, 2010 at 2:46 PM

I'm trying to do a PhotoSearch with the "SearchOption.Extras = SearchOption.Extras.Geo".  The search fails with the error "Parsing Exception was caught"....."Unknown attribute: geo_is_family=0".

I want to include Geo data in my search so I don't have to iterate through my results using GetPhotosInfo to get the geo data.

I can do a search when SearchOptions.Extras is not set, but the results do not include the Geo data (by design).   I've tried to do the search including various other SearchOptions (like Accuracy, HasGeo, etc), but all searches which include "SearchOption.Extras.Geo" fail as indicated above.

Am I missing something?  Thanks in advance for any responses.

Jun 4, 2010 at 9:37 PM

No, you're not missing anything. Flickr have obviously added some new attributes returned when specifying that value as an Extra.

I need to get rid of the line that throws an exception if that happens, and the re-release the code.


Jun 7, 2010 at 3:35 PM

Thanks!  I'll do it the long way until the update.

Jun 8, 2010 at 1:38 PM
Edited Jun 8, 2010 at 1:38 PM
Flickr obviously did add some new attributes. The Latitude and Longitude property of Photo object returns 0 even if a photo is georeferenced. When you are attending to the problem above, please check this as well. Regards, Matej
Aug 17, 2011 at 7:57 PM

Is there any solution yet that I could use to get the lat/long in the response from Flickr? I get the same error when using PhotoSearchExtras.geo or PhotoSearchExtras.All. ("Unknown attribute: geo_is_family=0")


Thank you,


Aug 17, 2011 at 9:42 PM

The latest release DLL should not throw an exception if new attributes have been added. Are you using the downloaded source code?


Aug 18, 2011 at 1:00 AM

Ah - that was my problem. I was using the example provided in the ZIP as a base for my project, which still had the old code. Overwrote the file in the Debug folder with the new ones and it works now like a charm. Again, thank you Sam!